Установка Phoenix Service.

1.Самый хороший вариант – это отдельный диск. Или отдельный логический диск с отдельной ОС Windows XP SP2, на которой будет только Phoenix (никаких антивирусов, Office-ов и т.д., ничего более). Если нет, тогда удалите с компьютера всё, что связано с Nokia (PC Suite, драйвера, папки, остающиеся после удаления, и др., особенно мешает Nokia_Conn_Cable_Driver). Очистите реестр от ненужных записей с помощью соотв. программ.

Также возможна установка на Windows Vista (в варианте без Диего, чтобы программа его не требовала, используется изменённая dk2win32.dll). При этом на файлах-инсталляторах и потом на самих исполняемых файлах программ надо будет включать режим совместимости с Windows XP.

2.Устанавливаем Diego v3.09 + донгл к нему. Внимательно смотрите путь, куда crack будет устанавливаться(по умолчанию – на диск С)! При необходимости – скорректируйте букву диска.

После установки проверьте работоспособность Diego, запустив его. Он должен запускаться без ошибок.

3. Устанавливаем Phoenix Service. Например, phoenix_service_sw_2006_44_6_163 + кряк к нему.

Версия «phoenix_service_sw_2006_20_9_148» также вполне работоспособна, а версия «phoenix_internal_service_sw_a_2006_27_0_238» имеет некоторые дополнительные функции, как, например, устанавливает в систему дополнительный Phone Browser – аналог Nokia PC Suite или Mobil Media Browser. Хорошие результаты даёт установка двойного Феникса, например, «phoenix_service_sw_2007_4_6_170» и потом поверх него «phoenix_internal_service_sw_a_2006_27_0_238» (+ кряк от 2007_4_6_170). Вы получаете двойной Феникс со всеми удобствами и дополнительными функциями!

3(1). Готовим кряк - донгл (из комплекта Diego). Запускаем, нажимаем «install», появится предложение заменить одни файлы другими. На этом пока остановимся (в варианте без Диего запрос на замену файлов может и не появится – они просто поставятся без запроса, в таком случае повторяем ещё раз).

3(2). Запускаем установку Phoenix Service. Во время установки появится сообщение, что она дальше не может быть продолжена, т.к. нет донгла. Нажимаем «повтор», быстро переходим к подготовленному выше кряку и нажимаем «Yes to All». Установка пойдёт дальше. Если не успели запустить кряк до повторного появления окна с сообщением – повторите снова. Во время установки возможно появления окон с ошибкой «DESkey not Found». Нажмите «OK» во всех случаях. После установки программы пойдёт установка недописанных системой драйверов. Везде нажать «продолжить в любом случае». Иногда сообщение об отсутствии донгла не появляется, особенно когда поверх одной ставиться другая

версия программы.

3(3). Устанавливаем crack_phoenix_service (или, Phoenix_update_0.1.0.1, в случае с версией 2007_4_6_170). Внимательно смотрите путь (букву диска), куда кряк устанавливается!

Теперь у Вас установлен Phoenix Service.

4. Устанавливаем Nokia_Conn_Cable_Driver, а ещё лучше - Nokia_PC_Suite, последнюю версию, рекомендованную для Вашей модели. Она ставит в систему необходимые компоненты и драйвера (в т.ч. Nokia_Conn_Cable_Driver, они входят в её состав), которые помогут системе увидеть и определить телефон.

5. Теперь устанавливаем нужную Вам прошивку.

6. Обязательно готовим телефон для работы с программой!

Подключаем ВКЛЮЧЕННЫЙ телефон к компьютеру. Windows должна поймать и установить драйвера для телефона. В Диспетчере Устройств должны появиться Wireless Comm Devices. Если система сама не видит телефон и пишет – «неизвестное устройство», то через Диспетчер Устройств обновите драйвер, указав вручную папку с Nokia_Conn_Cable_Driver. Или проверьте кабель и его подключение к разъёму телефона, перевоткните, почистите контакты. Всё это тоже может быть причиной.

Далее подключаем ВЫКЛЮЧЕННЫЙ телефон к компьютеру и на секунду нажимаем кнопку ВКЛ. на телефоне. Windows должна увидеть новое устройство, установить для него драйвер и сообщить об этом (всплывающим сообщением в трее). Нажимаем второй раз – ловим второе устройство. В Диспетчере Устройств, при нажатии кнопку ВКЛ. (на выключенном телефоне), эти два устройства появляются и через несколько секунд пропадают.

------------------------------------------------------------------------------------------------------------------------------------------------------------------

Если в Фениксе нет вашего RM в списке поддерживаемых моделей для прошивки, не спешите скачивать новую версию прошивальщика... Пробуем такой вариант - заходим в C:\Program Files\Nokia\Phoenix\ , находим файл конфигурации phoenix.ini, открываем его блокнотом и добавляем вашу модель девайса в строку инициализации (если нет) в два пункта, сохраняем и открываем Phoenix:

1. [Products]

RM-***=NMP.Product.Menu.A.1

2. [Productperformancecountermanagerfn]

PPCReadingMaxIndex=1031

[Phoenix]

[RM-***]

Description=Nokia ###

============================

Где *** - ваш RM по набору *#0000#

Где ### - ваш телефон/смартфон, например N76 или 5310

------------------------------------------------------------------------------------------------------------------------------------------------------------------

Ну вот, в общем-то, и всё.

Да пребудет с Вами Phoenix.


Прошиваем телефон.

(На примере Nokia 6233)

1. Вынимаем из телефона Sim-карту и карту памяти. Подключаем включенный телефон к компьютеру кабелем СА-53 или DKU-2 из комплекта поставки или «Original» (эти кабели – самый лучший вариант, остальные – как повезёт, т.е. никаких гарантий). Запускаем Phoenix Service. Выбираем соединение по USB.(В некоторых версиях Phoenix Service – через «File/Manage Connections»). Успешное соединение показывается в строке состояния (внизу программы).

2. Открываем «File/Scan Product». Программа сама определяет телефон, версию прошивки и показывает всё это в строке состояния (внизу программы).

3. Открываем «Flashing/Firmware Update». Появляется окно прошивальщика, в котором автоматически выставляется Product Code, какой есть в телефоне и версия прошивки. При необходимости можно выбрать другой Product Code вручную, нажав на квадратик и выбрав из списка имеющихся в прошивке.

4. Выбираем «Phone As Manufactured/Refurbish»(оно, как правило, ставится автоматически), или, в некоторых случаях, «Restore User Product» и жмём «Start». Во время прошивки кабель не трогать, не отключать и телефоном не пользоваться!

5. Начался процесс прошивки. Ход её показывает индикатор, а выполняемые в данный момент действия – надписи над ним. Во время прошивки телефон будет переходить в Test-режим и отключаться. Не беспокойтесь – это так и должно быть. По окончании процесса появится окно с надписью «Product Flashing Done», телефон включится и запросит разрешение на подключение без Sim-карты. Язык будет Английский. Включайте Русский через Меню.

------------------------------------------------------------------------------------------------------------------------------------------------------------------

В более ранних версиях Феникса (меню SW Update или Prommer Tools), или если прошивают мини-версией прошивки (два-три основных файла) используют метод указания программе нужных файлов для прошивки.

или

Добавляем в первую строчку (Image File) через Обзор, путь к файлу с

расширением .C0R, а во вторую строчку ( PPM File) файл с расширением .vXX

*.vXX – этот файл является языковым пакетом, где вместо ХХ будут цифры

Для смартфонов Nokia N70/90, сама прошивка является файлом с расширением .C0, а языковой пакет:

.V01 France, Alps

.V02 Turkey, South Africa

.V03 Scandinavia

.V04 Baltian

.V05 Russian, Ukraine, CIS, Bulgaria

Для Nokia 3250 в Фениксе прописываем следующие файлы: (пример от прошивки версии 3.21)

****ImageFile:

C:\ProgramFiles\Nokia\Phoenix\Products\RM-38\Thunder_03.21_Core.fpsx

****PPMFile:

C:\Program Files\Nokia\Phoenix\Products\RM-38\Thunder_03.21_Variant_05.fpsx

****ContentFile:

C:\Program Files\Nokia\Phoenix\Products\RM-38\Thunder_03.21_LFFS_Image_EMEA.fpsx

Для 6120с:

****ImageFile:

rm243_04.21_prd_core.fpsx

****PPMFile:

rm243_04.21_prd_vB05_01_russian.fpsx

------------------------------------------------------------------------------------------------------------------------------------------------------------------

PS. К сожалению, не всегда телефон прошивается удачно. Иногда он, как говорят, «умирает». Но это «умирание» - условно. Телефон по настоящему «мёртв» только в одном единственном случае – техническая неисправность. Во всех остальных случаях – он «жив», просто нуждается в программе, как компьютер в операционной системе (без неё он тоже «мёртв»). Для подобных случаев существует режим «Dead Mode».

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Иногда возникают ошибки, связанные с AdlLoader (Cmt->Data Intergity error when sending AdlLoader!) Решается это следующим образом:

1. скачиваем и устанавливаем последний NSU

2. Копируем все файлы из c:\Program Files\Common Files\Nokia\Service Layer\A\NslProductApi\ в c:\Program Files\Nokia\TssProductApiA\

3. Копируем все файлы c расширением adl из C:\Program Files\Common Files\Nokia\Tss\Flash в 3 папки:

C:\Program Files\Nokia\Phoenix\FlashUsb

C:\Program Files\Nokia\Phoenix\flash (создаёте сами)

C:\Program Files\Nokia\Phoenix\FlashHip

4. Запускаем Phoenix и начинаем прошивать телефон как описывалось выше.

Если по каким тому либо причинам вы не смогли скачать и установить NSU, то файлы из c:\Program Files\Common Files\Nokia\Service Layer\A\NslProductApi\

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Иногда после прошивки телефон не выходит из режима Test или Local Mode – зависает в нем «навсегда». В таких случаях помогает продедура снятия и установки обратно батарейки. Или самим Фениксом можно перевести режим в Test или Local, а потом обратно в нужный – Normal.


Краткий FAQ по прошивке телефона (Nokia 6233) в режиме «DEAD MODE».

Симптомы таковы: телефон может при нажатии кнопки ВКЛ. кратковременно включаться, показывать надпись «Nokia» и снова выключаться, а может вообще не подавать признаков жизни, не реагируя ни на что вообще.

Не забывайте, что аккумулятор должен быть заряжен, перед прошивкой поставьте хотя бы на час «мёртвый» телефон на зарядку. Заряд он всё равно должен воспринимать.

Кабель лучше всего использовать из комплекта поставки или «Original». Остальные, неизвестного происхождения – как повезёт.

Прошивка телефона в «DEAD MODE» не очень сильно отличается от обычного режима прошивки. Разница в типе соединения (не USB, а NO CONNECTION), выборе продукта вручную и галочки «DEAD MODE» в настройках. Ну и в том, что телефон находится в выключенном состоянии.

1. Подключаем телефон к компьютеру кабелем из комплекта CA-53 (или DKU-2).

2. Запускаем программу Phoenix Service. В появившемся окне входа пишем любое имя. Нажимаем ОК.

3. Выбираем режим соединения: NO CONNECTION. («File/Manage Connections»). Или передвигаем его на первое место стрелками справа, если у Вас уже был до этого выбран режим USB. Нажимаем «Apply». Закрываем окно.

4. Нажимаем «File/Open Product» – открывается окно, в котором Вы должны выбрать то, что Вам нужно (для Nokia 6233 , например, это Nokia 6233- RM-145). Открываем его.

5. Далее: жмём «Flashing/Firmware Update», напротив «Product Code» нажимаем на квадратик и выбираем свой код (для Nokia 6233 Black, например, это код 0535434 - RM-145).

6. Ставим галочку «Dead phone USB flashing». Наверху окна, где «Flasing Method», ставим «Phone As Manufactured / Refurbish» (как правило, оно само сразу или потом выставляется).

7. Нажимаем «Start». В окне пойдёт отсчет. В это время нажмите кнопку ВКЛ. на телефоне (если это делается в первый раз, то Windows «увидит» два новых устройства, сама их установит и сообщит об этом всплывающим окном в трее). Программа должна увидеть телефон и начнётся процесс прошивки. Когда прошивка закончится, появится окно, информирующее об окончании процесса. Телефон загрузится.

Если Вы не нажали кнопку ВКЛ. на телефоне, или программа его не видит, то выскочит окно с ошибкой:

Проверьте всё хорошенько ещё раз.

PS. Телефон загрузится и меню будет на Английском. Включайте Русский язык через «Настройки».

Если не шьётся «своим» продукт-кодом (телефон не загружается, выскакивает сообщение об ошибке и предложение прошить ещё раз), пробуйте другой продукт-код, где, предположительно, может быть Русский язык в меню (Белоруссия, Украина и т.п.). Сейчас главное – оживить телефон, а код Вы всегда успеете поменять на нужный.


Меняем Product Code с помощью NSS Прошиваем телефон с помощью Nokia Software Updater

Cкачиваем программу NSS (NEMESIS), устанавливаем её и запускаем.

Во время установки при выборе
Please select from the following Service device you will be using after the instalations
оставляем по умолчанию Virtual USB device

в верхнем правом углу нажимаем кнопу Scan for new device
после этого на закладку PHONE INFO
нажимаем кнопу SCAN
после того как появиться PHONE version и IMEI жмем кнопу READ и редактируем PRODUCT CODE
напротив PRODUCT CODE ставим галочку ENABLE и жмем кнопу WRITE
теперь телефон готов к перепрошивке через NSU Nokia Software Updater