Zero OS简介
一、简介
Zero OS基于webOS系统2.X.X修改，原名V++ROM，现在更名了Zero OS,简称ZERO
Zero OS维护者：@兰花大盗
二、支持设备
Veer 、 PRE/PRE PLUS 、 PRE2 、 PRE3
三、ROM功能简要说明
集成常用补丁，并在此基础上进行相应的优化，同时保留机器DIY特性，允许刷入标准patch补丁，方便功能扩展
四、个性化补丁推送
开机后在zero程序中可以找到本人精心推送个性化补丁
软件包——V++patch
软件包——V++update
五、ROM更新说明
1、大修改将以新ROM的形式释出
2、保留preware推送更新包与补丁的功能，便于查找
3、通过zero程序可以在线获取系统更新
六、快速搜索问题解决方法
推荐搜索关键的长度为两个字符，搜索不到请尝试使用意思相近的词汇
例如忠哲输入法，关键词可以是“忠哲”或者“输入”


01、 刷机常见问题

一、如何进入刷机模式

1、开机状态，一路运行刷机ROM，一路点下去，会自动进入刷机模式

2、针对veer，关机状态，长按音量键增加键+电源键 （电源键+来回拨动静音键：重启手机）

3、针对PRE ，关机状态，长按音量键，用数据线连接手机与电脑

三、刷机进度问题

1% ：手机ROM不适合设备使用，ROM跟机器不对应

4% ：novacom驱动的问题，无外乎重启电脑、换电脑、关闭杀毒软件、重装驱动等方法

12%或者8% ：请耐心等待；如果刷机刷到12%或者8%的时候，提示重置失败，不要着急，一般多刷几遍都会好。实在是弄不好只能论坛里找修砖工具了，其实没有变砖；不过修复的时候会格式化u盘的文件

52% :刷机ROM有损坏，请更换ROM

四、刷机刷基带的问题

1、VEER、PRE PLUS、PRE这三种设备默认会刷基带

2、PRE3、PRE2默认不会刷基带

五、关于超频

1、除了VEER2.2.4系统不能超频，其他设备都可以超频(别问我哪个核心比较好)

2、VEER 2.12默认集成超频核心，可以用Govnah调节频率；超频未必会增加耗电，有时还可以省电


02、开机后必看

刷机完毕第一次开机配置

1、开机后请感觉下图提示操作，请务必认真阅读【初用必看】页面的文字介绍

2、使用过程遇到问题，请在ZERO程序寻找解决方案，或者给我发邮件、微博咨询


03、常见问题

常见问题

如何快速解决问题 （请看完这一小段文字）

0、webOS系统天生残疾，问题多；请多花时间学习了解，本人也是从菜鸟自学走过来的
1、webOS的ROM跟安卓的定制ROM差异在于，不会因为定制出现奇怪的问题；你们碰到的问题基本其他人都会遇上，请搜索论坛寻找解决方法

不会因为说你刷了我的定制ROM就会出现，就算你刷其他的ROM也会出现类似的问题；这就是webOS的ROM

天生残疾，请多看资料、多学习、多搜索

2、善于使用关键字搜索，一般推荐两个字或者三个字长度作为搜索关键，使用同义词、相关关键词进行搜索找答案

3、此CHM花了本人大量时间收录使用过程常见问题，如果你不是高手，请花时间来阅读

1、短信无法正确显示联系人名字
原因:号码格式不匹配，解决方法有三
1)请修改号码格式
2)使用谷歌同步一下通讯录
3)使用系统自带备份，备份一下，然后使用impostah恢复备份

2、无法接收彩信
大致说一下思路：电话程序——菜单——网络服务——手动设置——编辑网络设置，重点来了：把用户名与密码设置为空的，然后点【改变设置】，接着选【无论如何都进行设置】，就可以了。针对移动网络cmwap跟cmnet都这么设置，联通方法类似

移动网关地址：10.0.0.172:80或者10.0.0.172:9201(原来是啥就是啥，如果无法接收彩信再改)

最大范围原来是300改为102400

图文教程相关教程：http://bbs.zoopda.com/thread-127020-1-1.html

3、媒体库问题(无法显示图片、音乐，无法拍照)

这个2.X系统都有个一个BUG，无法彻底解决，这里说一下几种解决方法
方法一：使用启动器(launcher)菜单里的重置媒体，基本可以解决复制音乐照片到设备无法被识别的问题；重置媒体可以解决阅读软件一直转圈的问题，操作完毕请重启手机

方法二：删除掉DCIM文件夹，然后去拍一张照片

方法三：(这个方法绝对有效)如果上面几种方法都无法解决问题，请直接格式化掉U盘，或者使用倒数第二个完全擦除

4、时间不准
请打开网络，使用启动器(launcher)菜单里的时间同步，顶部栏时间校正有延迟，请等一会

5、来电防火墙（黑名单）
在“联系人”中点击需要拦截的联系人，再点击左下角的铃声图标，设置来电动作为自动挂断

6、来去电归属地

由归属地补丁+归属地程序(数据库)构成，如果你一开始批量安装本人提供的软件，这个问题就搞掂了

安装完毕后，需要Luna重启或者完全重启手机才生效

归属地数据库更新问题

PS:由于此补丁与数据库的作者，没有提供更新数据库的方法，因此目前的数据库是无法更新的

7、通讯录(联系人)恢复不完整

可能会在2.24系统中出现，请将屏幕设置为常亮(屏幕&锁定里面设置)

8、设置短信铃声

短信程序——【选项&账号】——点击那个铃铛图标

9、短信没有声音

到短信程序的【选项&账户】里面设置一下，点击那个铃铛图标，里面提醒方式，反复设置几次就可以了

10、(忠哲)输入法问题

如果无法正常使用，重启手机，还是不行的话，卸载掉重装一遍

11、SmartOffice打开后黑屏

卸载掉重新再安装一遍

12、日历无法正常同步

由于Google在个别地区不稳定，导致同步失败，碰到这种情况只能多试几次

PS:本人所在地区gmail经常要反复登录好几次才登陆成功，其他国内邮箱基本已登录就成功了

13、手写输入法在哪里

请到preware里面搜索devicemenu，有详细介绍devicemenu所有功能(含隐藏功能)

14、开启了数据，看不到E字母

个别机器会出现这情况，解决方法：请打开飞行模式，过几秒在关闭飞行模式，等待一会看是否会出现；不行再来一遍。如果重启手机还是不行，你检是否开通上网流量服务，或者是否已经欠费

15、怎么快速切换3G与2G网络

长按devicemenu的 【网络数据】，会自动展开切换菜单

16、无法在线看视频、例如优酷、土豆等视频

原因：优酷、土豆网站对网站进行调整了

解决方法一：210系统这方法一直都管用，点击下载视频，弹出菜单后，选择在线打开

解决方法二：更新preware的源，搜索UA，根据情况选择UA，如果上水方法解决不了，推荐直接安装原版UA，安装完毕完全重启手机；这是一般打开 www.youku.com 时可以正常看视频，自己慢慢研究

17、耗电厉害

一般情况正常待机电流为3-6ma，手机静置后用DR.battery来检测

耗电异常可能性：

1、高强度使用

2、Google账户定时进行日历、邮件之类的同步 (我基本不用)

3、后台程序偷偷运行

18、英语纠错异常

一般中文状态会自动，输入的字母可能会被自动纠正成 汉语拼音；可以到【文本辅助】里面关闭掉纠错功能；或者更新preware源，软件包——V++patch，找到 Add en-cn补丁，看说明操作

19、补丁安装失败，无法安装

先判断是补丁冲突还是没有正常联网导致无法安装，具体可以看【日志】提示

1、可能此补丁本来就是无法正常安装的

2、设备内有补丁与此补丁有冲突

PS：常用存在冲突的补丁，我都在【第13章：补丁说明与卸载技巧】章节提到了；有冲突的补丁，一般都是内部已经集成功能类似的补丁，因为本人已经集成了大量打补丁，并进行了相应的修改优化；不要盲目刷补丁，如果真的缺了补丁再考虑安装补丁

20、批量安装软件功能是否允许自己添加软件

当然可以，详情请看：第10章批量安装APP

21、右上角菜单（devicemenu）

1）长按[重启手机]与[重启LUNA]才生效,减少误操作；
2）长按[亮度]关闭屏幕灯；
3）长按[网络数据]展开2G,3G网络选择；
4）短按[网络数据]开关GPRS上网数据
5）铃声、系统、多媒体音量控制，点击进行循环切换
6) 长按devicemenu第一个菜单调出手写输入法
7）重力感应需要安装重力控制软件才生效
8）合并GPS、VPN、蓝牙到一栏，更简洁
9）集成重力感应开关，需要安装xwtweak重力感应控制软件才生效(如果已经批量本人提供的软件，就默认安装此软件)

22、internalz(文件管理)没有移动、删除选项

到设置里开启管理模式即可（这个选项在底部）

24、应用商店无法使用

免激活ROM，需要到impostah激活设备，方可使用，第11章节有介绍

23、查找联系人，首字母查找联系人

ROM集成两种联系人首字母搜索方式

第一种：需要在联系人菜单里【更新拼音索引】，每次添加联系人都需要更新一次。此方式，不仅支持“姓名”+“名字”首字母查找联系人，还支持号 码搜索，例如手机号末尾四位数字搜索
例如联系人“煮机网”，输入zj或者jw都可以搜多到联系人
第二种：仅支持“姓名”首字母查找联系人，不支持“名字”首字母搜索
例如联系人名字叫“煮机网”，可以输入zj搜索联系人，但是输入jw是搜索不到的。此方法不需要每次添加联系人都更新拼音索引一次，只需在第一次 使用的安装建立索引即可，初次使用先安装Emergency reindexer；请安装 /media/internal/install-ipkgs/Pinyin-Index文件夹下的IPK
安装时间比较长请耐心等待，一次安装终身受用（刷机后重新来过），时间会长点，以后就不用管它
24、pre2 2.2.4系统壁纸重启后又回来，无法正常设置壁纸
部分机器会出现，部分机器不会出现，如果出现，删除掉这张壁纸就好了
/usr/lib/luna/customization/copy_binaries/media/internal/wallpapers/09.jpg
上述都是本ROM常见的问题，如果还有其他的问题，请现在论坛搜索，那些都是任意ROM常见问题
25、批量安装软件失败
1、最好是给我发安装日志，在/media/internal/文件夹下有log字符就是
2、或者重启手机后，重新批量安装
3、或者自己手动安装
26、收到通知手机自动重启（常见的收到短信重启）
使用时间久，通知栏会出现白条(块) ，请重启LUNA或者设备，即可解决

主要是通知栏中文文字导致，短信是造成白条(块) 主要原因

比较彻底的解决方法：

把短信通知栏提醒，设置成英文提示

此补丁在preware里面可以搜索到，在所有软件——V++patch里面可以找到

需要先卸载掉msg notification new msg

卸载方法：

1、首先更新preware的源，确保preware的V++源可以正常更新，否则不要轻易卸载补丁
2、卸载该补丁后，请不要离开当前页面，点安装再重新安装要卸载的补丁，安装完毕再次卸载此补丁
注意：
如果没有按照上述步骤操作，可能会导致该补丁没有被正常卸载掉
需要安装功能类似的补丁，必须要卸载对应的补丁才能安装其他的补丁，例如短信提醒补丁
必须先按照上述步骤卸载掉，才能安装其他短信通知栏提醒相关补丁


04、系统自身BUG

系统自身BUG

1、使用时间久，通知栏会出现白条(块) ，请重启LUNA或者设备，即可解决

主要是通知栏文字导致，短信是造成白条(块) 主要原因

2、快捷启动栏中的中文名应用，在波浪 状态下会出现乱码，目前无解

3、屏幕可能随机出现常亮状态，即无法锁屏，反复推开滑盖可解决

4、蓝牙无法收发文件(2.24系统，接收文件貌似保存在/tmp文件夹下)

5、devicemenu有时可能无法弹出，这个问题没有好的解决方法，重启设备可以解决

6、复制音乐，图片到u盘模式下，无法被是被识别出来

媒体库问题(无法显示图片、音乐，无法拍照)

这个2.X系统都有个一个BUG，无法彻底解决，这里说一下几种解决方法
方法一：使用启动器(launcher)菜单里的重置媒体，基本可以解决复制音乐照片到设备无法被识别的问题；重置媒体可以解决阅读软件一直转圈的问题，操作完毕请重启手机

方法二：删除掉DCIM文件夹，然后去拍一张照片

方法三：(这个方法绝对有效)如果上面几种方法都无法解决问题，请直接格式化掉U盘，或者使用倒数第二个完全擦除


05、解决MP3乱码的问题

MP3乱码主要是编码的问题，有些软件下载音乐是不会出现乱码，例如千千静听(百度音乐版)，如果出现乱码怎们解决，可以使用MP3tag软件来处理，软件下载页面： http://www.xiazaiba.com/html/113.html
一下方法来自论坛，发帖ID： gtdam 原帖： http://bbs.zoopda.com/thread-125941-1-1.html

1、进去程序，先在工具-选项里把语言改成中文

2、然后在选项-标签-MPEG里写入项改成 ID3V2.3 UTF-16 保存

3、找到你放歌曲的位置，加载后，在右边的列表点一下，按CTRL+A 全选了后，单击鼠标右键，点 保存标签，然后就把你原来存放的歌曲直接拷到你的手机里就ok了。


06、省电技巧

省电技巧

1、关闭后台数据与程序、自带备份(没有激活就不用管它)

2、推荐使用Dr.battery(电池医生)来查看电流情况，稳定情况(关闭所有程序，静置5分钟以上)待机电流为3-5mAh

3、如果发现稳定待机电流消耗不正常，请重启一下手机

耗电源头

1、系统自带备份偷偷在后台备份，当然你不激活系统，是不会备份

你跟不要想着去关闭备份，你没有激活设备，1000%是关不掉的

2、后台程序过多

像邮箱这种，登录邮箱后，别忘了设置同步邮件的频率，自动同步太频繁，会很耗电。有些人使用google账户，经常会忽略这一点，不经常用邮件的，到【账户】里面关掉

3、手机使用强度太大，例如安装了很多软件，或很大型的软件，都会导致耗电异常，重启手机可以矫正


07、备份与恢复

备份

1、系统自带备份

●可备份的项目:1)联系人，2)日历，3)任务，4)备忘，5)通话记录，6)信息，7)商店应用，8)程序相关配置，例如时区、书签、cookie(例如浏览器、新浪微博的密码)等.

●恢复备份:impostah登录账户，恢复备份.

2、蜡笔同步

联系人备份与恢复速度校对较慢

优点：所有备份可以在蜡笔网站的可以看到到

3、联系人本地备份与恢复

联系人菜单——通讯录管理——备份&恢复

4、短信备份、恢复、导出TXT可以显示人名

短信同步助手 ，本地备份有效保护隐私


08、系统全清（谨慎使用）

系统全清(针对本人的Zero ROM)
1、2013-03-09当前所有的ROM都增加防止忠哲输入全清导致屏幕失灵的补丁，可以有效的减少忠哲输入法因全清导致设备屏幕失灵的问题
2、全清不能完全恢复初始设置，后来自己安装的补丁都无法清除掉
3、一般推荐使用前三个【擦除】选项
4、【高级擦除】一般不需要选，太浪费时间了，也没有啥意义，除非你担心被人恢复你的数据，不然不需要选择此项
针对各类比较诡异的问题，可以考虑使用完全擦除（倒数第二个），多数情况可以解决问题


09、快捷键

常用快捷键
重启：方块键 + sys + r
截图：方块键 + sys + p
复制： 手势区 + c
黏贴：手势区 + v
剪切：手势区 + x
全选：手势区 + a
拍照： 空格键
系统浏览器快捷键
← 到顶部
┘ 到底部
空格 上一页
. 下一页
0 上一行
进入刷机模式(一般刷机连接数据线，运行刷机工具一路点下去会自动进入刷机模式)：
1、音量键增加键 + 电源键 (适用于veer等手机)
2、按住电源键 插上数据 （适用于Palm pre （plus）等手机）


10、批量安装App (IPK)

批量安装IPK使用说明 @兰花大盗 2012-12-10
http://weibo.com/170821465
一、功能简介
1、支持批量安装IPK
2、支持安装"按照指定按照顺序"安装的IPK
3、需要创建以下两个文件夹
/media/internal/zero/ipkgs （把需要批量安装的ipk放到这个文件夹）
/media/internal/zero/ipkgs-list （把"按照指定按照顺序安装"的IPK放到这个文件夹）
二、使用说明：
1、普通批量安装步骤
1)把需要安装的ipk复制到/media/internal/zero/ipkgs文件夹下
2)运行ZERO程序，初用必看——选择
2、安装"按照指定按照顺序"安装的IPK
1)把需要安装的ipk复制到/media/internal/zero/ipkgs-list文件夹下
2)并且在media/internal/zero/ipkgs文件夹下创建一个ipkgs.list的文件
3)安装的IPK的名字罗列个清单，按照以下的格式排版好，保存到ipkgs.list
以安装Internalz为例(不要有空行)：
ca.canucksoftware.js-service-framework_1.0.2.ipk
ca.canucksoftware.filemgr_2.0.9_all.ipk
ca.canucksoftware.internalz_1.5.0_all.ipk
三、注意事项:
1、所有安装的IPK，不得具备自动重启设备的功能，否则无法正常批量安装IPK


11、激活恢复设备

激活恢复

1、激活或创建账户
2、用系统自带备份备份一下系统，不管失败与否
3、恢复备份
4、palm账号管理
5、impostah优劣分析

一、激活或创建账户

二、请先用系统自带备份备份一下系统，然后再使用此程序，恢复备份

三、恢复备份

建议恢复一下备份,不然系统可能无法自动备份,恢复备份可以恢复联系人、短信、备忘录等数据,详情请查看备份程序。看下图,从图中我们可以看到有日期的那一栏，之前各个时间节点备份都可以看到，根据情况选择恢复指定的时间节点备份。
注意（
1、如果很在意自己palm账号显示，就往下看，不在意就别管了，不影响使用
2、如果恢复后看不到自己的palm账号，找一个很早之前的备份节点恢复
(恢复之前，建议全部删除通讯录的里联系人，避免联系人重复)
3、恢复最早的备份节点之后，此时再恢复自己上次备份的节点，保证恢复上次的备份

四、palm账号管理

免激活ROM，会多出一个skiped firstuse账号,可能还会多出一个SIM卡账号；
注意DatabaseKind栏，选择account:1
在选择 Query 进行查询
这里会出现手机上的所有账号，必须保留一个palm账号，不允许删除掉，否则会导致短信回话过期，这时候你将无法正常收发短信
注意:
1、如果该账户已经收发过短信的话，删除账户可能会导致“会话框过期”的提示

五、impostah优劣分析

优点：

1、开机后再激活设备，而且不需要重启手机就能恢复备份，节约时间

2、对于不使用系统自带备份的机油来说，本系统是免激活，不需要为账户烦恼

3、允许恢复不同时间节点的备份数据

4、跟开机登录效果基本一样，一样可以使用应用商店

缺点：

1、恢复备份的时候不会自动下载之前自己在应用商店下载的APP，需要重新下载

2、不恰当使用impostah，容易导致恢复备份后看不到自己的palm账户，不影响正常使用

如果看不到自己的palm账号，建议找一个时间最早的备份来恢复，接着清空通讯录，然后恢复上次的备份

六、不小心删掉了Dr.Skippde.Firstuse

一下找回Dr.Skippde.Firstuse的方法，用WQI或者WFT链接手机，调出linux命令，输入一下命令(请复制黏贴)
luna-send -n 1 palm://com.palm.accountservices/createNovaAccount '{"createDefaultAccount":true}'


12、Dr.Skippde.Firstuse阴魂不散

大概说一下Dr.Skippde.Firstuse账号，只要是跳过激活，就会出现这个账号，主要方便开发者直接调试系统
不过很多看到这个账号就不爽了，太碍眼了，下面讲一下怎么弄掉这个账号，同时保证短信不被锁住
方法如下：
1、开机直接登录激活设备
免激活的ROM，如果需要开机登录激活，需要创建这么一个文件
/media/internal/jihuo.txt
这样刷机完毕后，就可以直接登录账号后
2、Dr.Skippde.Firstuse已经出现
使用impostah登录激活设备(教程搜索一下)，找一个最早备份恢复(一般情况惠普在早之前偷偷帮你备份过)
如果你之前一直是开机直接登录激活设备，恢复备份完毕后，基本是可以看到你的原来注册的账号ID
这个时候，你看Dr.Skippde.Firstuse不爽可以删掉
请确保机器存在一个palm账号，否则会导致短信会话过期，将无法正常收发短信
3、不小心删掉了Dr.Skippde.Firstuse，短信发不了
一下找回Dr.Skippde.Firstuse的方法，用WQI或者WFT链接手机，调出linux命令，输入一下命令(请复制黏贴)
luna-send -n 1 palm://com.palm.accountservices/createNovaAccount '{"createDefaultAccount":true}'
4、短信会话被锁住(回话过期)
1）必须确保你的机器一定要存在一个账号，否则会用锁住
2）有账号还被锁住，首先用蜡笔同步或者本人的【 短信同步助手 】备份一下短信，然后清空掉，再恢复到手机里


13、已集成补丁卸载说明

Zero（V++ROM）默认集成常用补丁，并在基础进行深度优化，有些补丁允许卸载有些补丁不允许
一、卸载已集成补丁须知
1、首先更新preware的源，确保preware的V++源可以正常更新，否则不要轻易卸载补丁
2、卸载该补丁后，请不要离开当前页面，点安装再重新安装要卸载的补丁，安装完毕再次卸载此补丁
注意：
如果没有按照上述步骤操作，可能会导致该补丁没有被正常卸载掉
需要安装功能类似的补丁，必须要卸载对应的补丁才能安装其他的补丁，例如短信提醒补丁
必须先按照上述步骤卸载掉，才能安装其他短信通知栏提醒相关补丁

二、ROM内默认已经允许卸载的补丁如下

1、GPS&静音图标 (preware里搜索GPS)

此补丁与advanced framework menu有冲突
2、顶部栏星期补丁 (preware里搜索week)
3、devicemenu顶部栏补丁 (preware里搜索devicemenu)
功能介绍
1）长按[重启手机]与[重启LUNA]才生效,减少误操作；
2）长按[亮度]关闭屏幕灯；
3）长按[网络数据]展开2G,3G网络选择；
4）短按[网络数据]开关GPRS上网数据
5）铃声、系统、多媒体音量控制，点击进行循环切换
6) 长按devicemenu第一个菜单调出手写输入法
7）重力感应需要安装重力控制软件才生效
8）合并GPS、VPN、蓝牙到一栏，更简洁
9）集成重力感应开关，需要安装xwtweak重力感应控制软件才生效(如果已经批量本人提供的软件，就默认安装此软件)
4、短信通知栏提醒
到已经安装软件包——V++Patch里面找
如果想安装其他的短信通知栏提醒补丁，必须按照卸载已集成补丁须知方法卸载掉msg notification new msg
5、短信回车换行补丁（preware搜索new line）
6、基本就这些补丁允许卸载，其他补丁不影响个人定制


14、Today menu使用方法

功能效果：
today menu配合google同步可以实现又图的功能：可以显示天气、中国假日、当天事件等
这个需要登录电脑版的gmail的日历里面设置才可以，这里放一个教程，不要问我是怎么弄出来，自己看着教程弄
http://bbs.zoopda.com/thread-37173-1-1.html
安装步骤（记得先更新preware源）
1、先卸载掉GPS补丁，到preware搜gps
2、安装advanced framework menu补丁
安装了此补丁，就不能安装电量百分比补丁
3、安装today menu补丁
4、安装tweak，然后运行调节参数
5、完全重启手机
6、登录google 日历账户后，同步就可以显示右图效果
额外付费赠送补丁说明：
1、内含精简版advanced framework menu补丁
此补丁不与电量百分比补丁有冲突，意味着自己可以刷入自己喜欢电量百分比补丁，可以在右图基础上刷一个”环形电量补丁“


15、卸载系统自带软件

推荐使用WFT(webOS File Transfer)来卸载
WFT是本人开发一款工具，好东西谁用谁知道
下载地址： [6.22更新] 简易文件传送WFT3.6【支持安装ipk】
介绍几个特殊的功能
1、批量发送文件到设备里
2、可以卸载系统自带的软件 【webOS系统APP卸载】
3、可以下载preware里看到的软件与补丁
4、可以卸载WQI无法正常卸载的补丁或者应用


17、科学而简易刷基带FW方法

一、FW对机器的影响
Fireware(FW)这个东西控制着手机的上网与网络,版本不对会导致无法上网或者无服务或者手机离线等问题
刷错FW可能会变砖了,我没有测试过刷错FW,不了解刷错了会是怎样的
二、何时需要刷基带FW
1、pre （plus）
pre (plus) 从1.X 刷成 2.X系统需要刷基带,或者2.X系统刷成1.X需要刷基带；2.X刷2.X或者1.X刷1.X可以不用刷基带
简而言之就是跨版本刷机，要刷基带
注：本人pre (plus) 的ROM默认刷FW的，电信机器(C网写号机器)要基带FW请按照下面方法来操作
2、Veer
Veer 2.12刷2.24 或者 2.24刷2.12都需要刷基带
注：本人的veer所有ROM都是刷基带的，也不需要刷官方ROM，再刷ROM，直接就可以了
3、Pre3
pre3 基带这东西跟它没有半毛钱关系
4、Pre2
pre2 2.10与2.24的基带是一样，但是有极个别机器仍然需要刷基带
注：本人pre2 系列ROM都是不刷基带，如果要刷基带，参照一下方法来操纵
5、pixi
我没有发布过这个设备的ROM
三、最科学最安全的刷基带方法,具体操作步骤 （压缩工具请选好压）
1、找到对应版本的FW
请找一个官方的ROM，且ROM的版本要对应，如果你现在刷的是2.1.0的ROM就找一个官方的2.10的ROM
为啥要找官方的ROM，因为官方ROM的FW比较纯正，FW的版本也能对应起来
或者找你之前一直刷的基带FW也是可以的
2、提取FW，以官方的ROM的FW为例
用压缩工具打开ROM，进入resource文件夹，找到webOS.tar，打开它
你看到两个含有FW字样的扩展名为tar的文件，把这两个东西拖出来(或者解压出来)
这两个东西就是我们要找的FW,下面会用到(关键是有大小那个tar文件，大小为0的那个可以不用管它)
关闭掉webOS.tar与官方ROM
3、为定制ROM添加FW
现在用压缩工具打开你要刷的ROM(例如V++ROM)，进入resource文件夹，找到webOS.tar，把这个东西拖出来，拖出来后用压缩工具打开它，注意看下面的操作：把刚才提取出来含有FW字样的两个tar文件(选大小最大的那个就可以了，另一个大小为0的可以不用管)，拖到到这已经打开的webOS.tar里面，然后关闭掉webOS.tar。把这个修改好的webOS.tar拖到定制ROM(例如V++ROM)的resource文件夹下,等待重新压缩完毕
4、操作完毕
按照上述步骤完成对定制ROM的FW基带的添加，这样以后只要直接刷自己修改好的定制ROM，就不需要开机再去刷基带FW
这样操作简便又安全
四、不刷基带的方法
不刷基带的好处：
1、可以加快刷机速度，自行决定
2、刷机相对安全些
3、跨版本刷机一定要刷基带FW(上述已有描述)
如何刷机的时候不刷基带：
1、用压缩工具打开你要刷的ROM(例如V++ROM)，进入resource文件夹，找到webOS.tar，把这个东西拖出来
2、打开webOS.tar，删除含有fw字样两个文件（一般是两个，有几个删几个）
3、把修改好的webOS.tar拖回到resource文件夹下
4、等待压缩包完毕，操作完毕
5、可以刷机了


18、简易美化技巧(一)

如何高效的替换手机内部图片
准备工具，建议使用好压压缩工具
大概说一下，图片都藏在哪个地方，其他的你自己找找
电量图片：/usr/lib/luna/system/luna-systemui/images
呼吸图片：/usr/palm/sysmgr/images
程序图标：/usr/palm/applications这个文件夹对应着程序的ID文件下，自己找找
/media/cryptofs/apps/usr/palm/applications这个文件夹对应着程序的ID文件下，自己找找
以message(信息)程序为例，图标藏在/usr/palm/applications/com.palm.app.messaging文件夹下
菜单，laucher界面，参考一下教程中veer212-blackglass压缩包内文件路径，不同的ROM，路径有一定的差异
一、如何很好的了解手机内图片所在位置
1、用压缩工具打开ROM，进入resource文件，打开webOS.tar文件，看到最大的那个tar.gz文件，把它给拖出来
2、用压缩工具(推荐用好压右键打开)打开这个巨型的tar.gz文件，你会发现文件结构跟手机内文件结果惊人的相似，其实就是把这个巨型解压到手机内，所以文件夹结构是一样的
3、如果你要解压这个巨型文件也行，时间相对长一些，如果报错的不用管它(是否解压自己看着办)
顺便说一下，这个压缩包不会有/media/cryptofs/apps/usr/palm/applications这个路径，只有手机里有
二、开机第一屏logo替换
貌似2.X系统都是需要刷机才能替换，1.4系统我没有用过，下面讲一下操作方法：
1）好压（也可以用7z）打开ROM，进入resource文件夹，把webOS.tar拖出来
2）用好压打开webOS.tar，看到BootLogo.tga，这个就是开机第一屏图片（用PS或者好压自带看图工具可以查看）
用photoshop可以将图片格式保存为tga格式；千万别直接重名把其他格式图片直接改为tga格式
3）把需要替换的BootLogo.tga拖到webOS.tar里面
4）把修改好的webOS.tar在拖出去到resource文件夹里面
三、机器内部美化技巧(例如电量美化)
传统方法：用WQI一张一张图片的发进去，这个实在是太疯狂了
高级技巧：把需要替换的图片按照手机内图片所在位置(路径)，在电脑上放好，然后用好压打包成tar.gz格式压缩包
还有更好用的方法，就是用个无线传输(ROM内有无线传输教程)，这里就不讲了
这里有打包好的美化包，下载地址： http://pan.baidu.com/share/link?shareid=414883&uk=3861023915
这是一个veer212的美化包，以此为例讲解
1、先下载好链接中的美化包
2、用好压选中文件，右键【解压到 “veer212-blackglass\” (E)】，进入文件夹后会看到usr文件夹，继续点击进入会发现这些图片都对应着手机内指定位置
3、参考着veer212-blackglass文件夹内部的结构，放置好自己的美化图片或者修改好的文件(放文件需要慎重，如果文件修改有误，可能会导致无限重启)
4、放好自己的美化图片或修改好的文件之后，进入veer212-blackglass文件夹下，选择usr文件夹，右键【添加到压缩文件】，记住是一定要用好压来操作，会弹出以下对话框(看下图)。压缩文件名不得为中文，压缩文件格式为TAR.GZ；然后点确定开始压缩打包
5、美化包算是打包好了
6、把美化包usr.tar.gz(下图压缩好就是这个名字)传到手机里的/media/internal文件夹下
推荐使用WQI(或者WFT)来传送到手机，后面还有用到WQI(或者WFT)
7、传送完毕后，用WQI连接手机，调出linux命令行，输入一下两条命令(直接复制黏贴)
mount -o rw,remount /
tar -xvzf /media/internal/usr.tar.gz -C /
8、等待解压完毕 ，luna重启手机，美化就会生效


19、简易美化技巧(二)

四、如何定制自己美化ROM
很多机油刷机完毕，都会添加自己美化图片，或者修改某些文件；下面的方法就是教授如何定制属于自己的个性ROM
不了解系统内部文件的，最好只是美化图片，不要替换文件
准备工具：好压 、 Ipk Packager.jar
以veer212的黑色半透明主题为例讲解，所需文件下载地址：
http://pan.baidu.com/share/link?shareid=416241&uk=3861023915
http://pan.baidu.com/share/link?shareid=416245&uk=3861023915
1、用好压右键解压 【解压到 "\blackglass.212_1.0_all" (E)】
2、进入blackglass.212_1.0_all文件会看到，control与data两个文件
3、选中control，右键【解压到当前文件夹】
4、选中data，右键【解压到 "\data" (E)】
点击进入data文件夹，会发现usr文件夹，你会发现usr文件夹下图片跟手机内图片路径是对应的；把自己的美化图片或者修改好的文件，按照手机内的对应的路径放置好(没有文件夹自己建立)
5、美化图片(文件放置好)，下面开始打包，运行Ipk Packager.jar，看到下图的效果
6、点击Folder右边的按钮，浏览找到步骤4解压得到的那个data文件夹，选中data文件夹
ID可以自己修改，必须是英文字母或者数字组合，不得为中文；你自己认得就行
其他的东西改了你自己也看不到，改不改都无所谓
7、点击【生成IPK文件】，就这样搞掂了 （还没有结束继续往下看）
把打包好的IPK放到ROM完成，完成自己美化定制ROM
8、用好压打开ROM，进入resource文件夹，找到att.tar（wr.tar，也可能叫其他的名字，最小的那个tar文件就是了），把att.tar（wr.tar），拖出来
9、用好压打开att.tar（wr.tar)，你看到里面有很多IPK文件
10、把自己刚才打包好的IPK文件拖进去，等待压缩完毕
11、把修改好的att.tar（wr.tar)，拖回到resource文件夹内，替换掉原来的文件
12、等待压缩完毕后，自己的美化定制ROM就大功告成了


20、正确求助方法

 经常会收到各种求助，有时不是别人不想回答帮助你，是问题描述实在得太简单了，别人根本无法确定问题在哪里。很多人总喜欢发这样求助帖：“我肚子疼”，肚子疼的原因很多种，可能是吃坏了东西，可能是受伤了，可能是要生了，或者可能是其他的原因。面对这样提问方式，我需要反复来一问一答，才能知道具体是啥原因知道具体是什么原因导致肚子疼。这样不仅不能快速的解决问题，还浪费大家的时间，像这样的问题没有几个人想去回答了，还有很多问题只要在论坛搜索一下就能找到答案，你不去搜索，一上来就求助，谁有那么多时间精力去回答的你问题。本人是从webOS小白走过来，但是本人在论坛发的求助帖极少，因为大部分遇到的问题都可以在论坛里搜索找到我想要的答案，竟然你选择webOS，你就需要多点耐心，善于使用论坛搜索寻找答案。
如何让自己的问题得到快速的解答，就麻烦求助的机油，把问题描述的详细点，你描述的越详细又有利于其他人分析问题，找到问题所在，快速帮你解决问题。遇到问题建议先搜索论坛，我不知道是不是还有人不会使用搜索功能，其实你遇到的问题，多数都是别人都可能曾经遇到多，只要论坛搜索一下就能找到答案，不要把自己的问题当做另类，认为只有你自己才会遇到过，别人没有遇到过。我一度怀疑很多人不知道怎么搜索，搜索就是靠关键字来找答案，关键字不是越长越好，也不是越短越好，一般关键字是两个字(符)比较容易找到答案，如果这个关键字找不到答案，换跟关键字意思相近的词汇继续搜索，如果无法从一段话里提炼出关键字，请回去先把语文老师救活。如果确实是找不到答案，再发帖求助，下面说说怎样发帖子求助，才可以快速得到解决，鉴于别人无法知道你搞机水平如何，请参考一下格式发求助帖

webOS设备相关求助帖子问题描述参考格式：

1、设备类型
PRE2 \PRE3 \VEER \Palm PRE \PRE

2、系统版本
2.1.0 \2.2.4 \2.1.2 \1.4.5
这个信息可以在设备信息里看到

3、定制ROM版本、编译日期
这个一般是定制ROM的作者约定的
一般的ROM名字都会有说明

4、问题描述（症状）
1）说清楚是啥问题
2）啥时候出的问题
3）出问题之前是否正常，出问题之前有什么操作
4）出问题之后是如何处理的，处理结果如何

结语：
发帖求助，问题描述的越详细、调理越清晰，问题越容易得到解决。


21、使用条款

使用条款
1、未经许可不得提取本ROM资源进行修改，或者二次发布
2、不得用于商业用途
3、不得传播此CHM帮助文件，无线传输教程
@兰花大盗